!

My Pitt Video (Panopto) Recorder Update Required for Users Effective September 15, 2017

Friday, September 1, 2017 - 11:46

My Pitt Video Recorder, powered by Panopto, is a component of My Pitt Video that enables users to create video content. Beginning Friday, Sept. 15, 2017, users of the My Pitt Video Recorder client must use version 5.4 or higher to create video content.

If you are using version 5.3 or earlier of the My Pitt Video (Panopto) Recorder, you will see an update message when you log in to the client on September 15. To prevent uninterrupted use of an affected My Pitt Video Recorder version, you should install the latest client from Panopto before September 15. Instructions for completing the installation process are available for Windows or Mac

To see if your Recorder is affected, launch the Recorder from your computer. Your version number is listed in the Settings for the Recorder. If you need to upgrade, you do not need to uninstall a previous version. However, installation of the Recorder does require administrative rights to your Windows computer, or the credentials of an administrator account on the system for Mac, and may need to be performed by your IT contact. If you have questions about administrative rights, you should contact your department’s IT contact. 

Please contact the Technology Help Desk at 412 624-HELP [4357] if you have any questions about this announcement.